- 1、本文档共16页,可阅读全部内容。
- 2、有哪些信誉好的足球投注网站(book118)网站文档一经付费(服务费),不意味着购买了该文档的版权,仅供个人/单位学习、研究之用,不得用于商业用途,未经授权,严禁复制、发行、汇编、翻译或者网络传播等,侵权必究。
- 3、本站所有内容均由合作方或网友上传,本站不对文档的完整性、权威性及其观点立场正确性做任何保证或承诺!文档内容仅供研究参考,付费前请自行鉴别。如您付费,意味着您自己接受本站规则且自行承担风险,本站不退款、不进行额外附加服务;查看《如何避免下载的几个坑》。如果您已付费下载过本站文档,您可以点击 这里二次下载。
- 4、如文档侵犯商业秘密、侵犯著作权、侵犯人身权等,请点击“版权申诉”(推荐),也可以打举报电话:400-050-0827(电话支持时间:9:00-18:30)。
查看更多
ACM之基本输入与输出教程
ACM之基本输入与输出
一、基本输入
1.输入第一类
输入不说明有多少个Input Block,以EOF为结束标志。 参见:HDOJ_1089
HYPERLINK /showproblem.php?pid=1089 \t _parent /showproblem.php?pid HYPERLINK /showproblem.php?pid=1089 \t _parent =1089
A+B for Input-Output Practice (I)
HDU-1089
Time Limit: 2000/1000 MS (Java/Others)????Memory Limit: 65536/32768 K (Java/Others)Total Submission(s): 15945????Accepted Submission(s): 9583
Problem Description
Your task is to Calculate a + b.Too easy?! Of course! I specially designed the problem for acm beginners. You must have found that some problems have the same titles with this one, yes, all these problems were designed for the same aim.
Input
The input will consist of a series of pairs of integers a and b, separated by a space, one pair of integers per line.
Output
For each pair of input integers a and b you should output the sum of a and b in one line, and with one line of output for each line in input.
Sample Input
1 5
10 20
Sample Output
本类输入解决方案:
C语法:
while(scanf(%d %d,a, b) != EOF)
{ ? ? .... }
C++语法:
while( cin a b ) { ? ? .... }
C语法:
while(scanf(%d %d,a, b) != EOF)
{ ? ? .... }
C++语法:
while( cin a b ) { ? ? .... }
6
30
Hdoj_1089源代码
#include stdio.h
int main()
{ int a,b;
while(scanf(%d %d,a, b) != EOF)
printf(%d\n,a+b);
return 0;
}
注意:
Scanf函数返回值就是读出的变量个数,如:scanf( “%d %d”, a, b ); 如果只有一个整数输入,返回值是1,如果有两个整数输入,返回值是2,如果一个都没有,则返回值是-1。
EOF是一个预定义的常量,等于-1。
2.输入第二类
输入一开始就会说有N个Input Block,下面接着是N个Input Block。 参见:HDOJ_1090
HYPERLINK /showproblem.php?pid=1090 \t _parent /showproblem.php?pid HYPERLINK /showproblem.php?pid=1090 \t _parent =1090
A+B for Input-Output Practice (II)
HDU-1090
Time Limit: 2000/1000 MS (Java/Others)????Memory Limit: 65536/32768 K (Java/Others)Total Submission(s): 12438????Accepted Submission(s): 8620
Problem Description
Your task is to Calculate a + b.
Input
Input contains an integer N in the first line, and then N lines follow. Each line consists of a pair of integers a and b, separ
文档评论(0)