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1 Introduction

1 Introduction

The purpose of these exercises is to introduce PowerFactory ’s functions for power system har-
monic analysis in power systems. The drills include setting up network models, running har-
monic load flows and frequency sweep simulations, and plotting and interpreting the results.

The instructions in the exercises are deliberately brief to encourage a bit of trial and error while
performing a certain task. The supervisor(s) will help you with the exercises. Additionally, the
references between brackets point to detailed instructions to the exercises in the appendix.

Finally, do not hesitate to address the supervisor(s) at any time! They can provide answers to
general questions regarding the topic of the training.

We wish you good success!
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2 Creation of a first project and entering of network data

2 Creation of a first project and entering of network data

In this first exercise you will get introduced to the basic concepts of PowerFactory. You will start
building a 110 kV grid from scratch and enter elements and types.

• Create a new project with the name ”PF Seminar”. [A.1].

• Name the grid ”110 kV grid”.

• Rename the diagram ”Scheme 110 kV grid”.

• Make the background layer visible and select the file ”PF Seminar 110 kV grid” as the
background picture. [B.2]

• Change the drawing format from landscape to portrait.

• Enter the network elements of the 110 kV grid as given in figure 2.1 as follows:

• Add the single and double busbar elements to the 110 kV grid. Ensure that the busbar
voltage is set to 110 kV.

• Change the names of the single and double busbar objects according to figure 2.1.

• Use a terminal element to represent the 380 kV busbar. Change the voltage to 380 kV.

• Use the short terminal element to represent the 10 kV busbars between the generators
and the transformers.

• Connect the busbars with the line elements.

• Add the transformers, generators and the external grid to the network.

• Import the library folder Types.dz. This library folder contains some types. Others will be
created by you. [A.3]

• Create the line types ”N2XS(FL)2Y 1x300RM/25 64/110kV it”, the transformer typ ”T-150
MVA” and the generator type ”46 MVA” by using the data sheets given in the attachment.

• Add the types to the elements as given in the tables 2.1 to 2.6 and enter the element data.
Any parameters which are not provided should be left at their default values.
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2 Creation of a first project and entering of network data

Figure 2.1: 110 kV network
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2 Creation of a first project and entering of network data

Figure 2.2: Line data
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2 Creation of a first project and entering of network data

Figure 2.3: Generator data
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2 Creation of a first project and entering of network data

Figure 2.4: Transformer data

Table 2.1: Lines and Cables

Name Type Length
L-1-1 N2XS(FL)2Y 1*300 10.00 km
L-1-2 N2XS(FL)2Y 1*300 10.00 km
L-2-1 N2XS(FL)2Y 1*300 25.00 km
L-3-1 Al/St 150/50 50.00 km
L-3-2 Al/St 150/50 50.00 km

Table 2.2: Transformers

Name Type Tap position
T-1 T-380/110-150MVA 14

T-KW-1 T-110/10-60MVA 0
T-KW-2 T-110/10-60MVA 0

le Sk”max Sk”min
Ext-380kV SL 1.02 p.u. 0.00ı̈¿½ 8000.00 MVA 7000.00 MVA
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2 Creation of a first project and entering of network data

Table 2.4: Generators

Name Type Mode voltage control Active power Voltage
Gen-1 46 MVA voltage 30.00 MW 1.00 p.u.
Gen-2 46 MVA voltage 30.00 MW 1.00 p.u.

Table 2.5: Loads

Name Dispatch Active Power Dispatch: Power factor cos( )
BL-UW1 22.00 MW 0.86
BL-UW2 35.00 MW 0.88

BL-UW3.1 46.40 MW 0.85
BL-UW3.2 50.00 MW 0.85

Table 2.6: Busbar type

Name Voltage ip ith
SS 110 kV 110 kV 30 kA. 16kA 1s

• After the network data has been entered, make the background layer invisble again. [B.2]

• Define a title for the project and add the DIgSILENT logo to the title. [B.1]

• Add the transformer tap positions layer to the grid. [B.2]

• Change the colouring mode to voltage levels. [B.4]

• Activate the colouring tool bar and change the position so that it fits in the single line
diagram.

• Run the data verification with the options check topology and check input parameters
activated.

• Export the scheme as a .wmf file. Select File → Export→ Windowsmetafile to do so.

• Create a report for the documentation of device data.
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3 Load flow analysis

3 Load flow analysis

In thi ercise you will verify the entered data of your project and you will be introduced to the
load flow calculation tool. In addition, you will learn how to access results.

3.1 Load flow calculation

• Run the load flow analysis . Deactivate all options beside ”AC load flow, balanced, positive
sequence”.

• Check the messages in the output window to verify if there are any warnings or error
messages (warning messages will be shown in red colour) and correct the mistakes if
there are any listed.

• Once mistakes are corrected repeat the load flow calculation.

3.2 Evaluation of results

Results can be assessed and listed in the following ways:

3.2.1 Results in the network scheme

• Add the ”direction arrows” layer to the grid. The direction shown corresponds with the
direction of active power flow. [B.2]

• Be aware that the colouring mode automatically changes after a load flow calculation to
high voltage / low voltage / loading. [B.4]

• Evaluate the results shown in the result boxes.

• Add the legend for the results to the single line diagram. [B.5]

• Fill out Table 3.1 on the next page with the calculation results

Table 3.1: Calculation results

Calculation result Value
Lowest voltage in p.u. / name of busbar

Highest loading of a line / line name
Active Power at HV side of T1

Reactive power at Lv side of T1
Total network losses Active power

• Choose the ”loading” result box format for the edge elements (lines, transformers, gener-
ators, etc.) and evaluate the results.

• Select the ”power loading” result box format for edge elements and observe the changes
in the listed variables.

• Add the voltage deviation to the result boxes for the nodes.

Load flow and short circuit calculation (Training Exercises) 10



3 Load flow analysis

• Add the current to the result boxes for the edge elements. [D.2]

• Change the unit for the current from kA to A. [D.5]

• Create a textbox for the transformer T1 and add the variables active and reactive power
losses to the transformer losses

3.2.2 Using the flexible data page to access results

• Open the browser to edit relevant objects for calculation. Select all busbars

• Go to the flexible data page and sort the list according to the voltages in p.u.

• Define a flexible data page for the busbars and include the listed variables for busbars:

Table 3.2: Flexible Data page 1

U Ul u u du U,angle
kVı̈¿½ kV p.u. per cent per cent deg

• Define a flexible data page for the grid and select the listed results:

Table 3.3: Flexible Data page 2

Dispatch, Active Power General load, Active Power Losses Line losses
MW MW MW MW

3.2.3 Result documentation

• Create an ASCII report for the total grid summary and observe the results in the output
window. [D.7]

• Create an ASCII report for the complete system report.

• Save the report from the output window into a text file. The output file name should have
the file extension .out.

• Re-do the load flow calculation. This time enable the option ”Show verification report”on
the outputs page of the load flow command. All elements with a loading higher than 60
per cent should be listed in the output window. [D.11]
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4 Load flow calculation under consideration of voltage control and reactive power limits

4 Load flow calculation under consideration of voltage con-
trol and reactive power limits

As you may have realised in exercise 2, the voltage on some busbars in the 110 kV grid is
relatively low. To support the voltage in the grid, we will use firstly use a station controller. We will
then consider the reactive power limits and capability curves of the generators., The adjustment
of transformer taps to find the best operation point of the system will also be examined. Finally
we will get to know switchable shunts.

4.1 Station controller

• Define a station controller for the generators Gen-1 and Gen-2. [C.1]The station controller
should control the voltage of the busbar S1 of the substation UW-1. The voltage setpoint
is 1.02 p.u. To achieve this, the reactive power provided by the generators, should be
shared equally.

• Run the load flow calculation. Has the new setpoint be reached? Are there any overloaded
elements?

• Deactivate the station controller by using the object filter. Re-run the load flow calculation.
Compare the results. [C.2]

• Activate the station controller again and repeat the calculation.

4.2 Consideration of reactive power limits

• Set the reactive power limits of the generators ”Gen-1” and ”Gen-2” to -12 Mvar / +30
Mvar.

• Rerun the load flow calculation. Are there any warnings listed in the output window?

• Rerun the load flow calculation again. This time enable the option ”Consider reactive
power limits”. Are there any changes in the results? Can the voltage setpoint of the
station controller be reached? If not, why?

4.3 Generator capability curve

By considering the generator capability curve the reactive power limits can be entered precisely.

• Create a new capability curve for the first generator. Use the values given in table 4.1.
Take care to use the limits in p.u. instead of in MVA. [G.1]

• Select the new capability curve for the second generator, too. [G.2]

• Run the load flow calculation again and check the output window for warnings.

• Open the input window of the generator Gen-1 an vigate to the load flo ge to see
the new dispatch point in the diagram.

• Rerun the load flow calculation and enable /disable the option ”Consider reactive power
limits”.
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4 Load flow calculation under consideration of voltage control and reactive power limits

Table 4.1: Capability Curve

Active power Min. reactive power Max. reactive power
p.u. p.u. p.u.
0 -0.4 0.86

0.3 -0.3 0.83
0.6 -0.19 0.72
0.8 -0.12 0.6
0.9 -0.08 0.4

0.95 -0.06 0.3
1 -0.04 -0.04

4.4 Automatic tap adjustment of transformers

The voltage can be controlled by changing the tap position of a transformer.

• Activate the option ”Automatic tap adjustment” on the load flo ge of the transformer
elements T-KW 1 and T-KW2 to control the voltage on the HV side: [C.3]

– Controlled Node: HV

– Tap changer: direct

– Control mode: V

– Upper voltage bound 1.05 p.u.

– Voltage setpoint: 1.03 p.u.

– Lower voltage bound: 1.01 p.u.

• ” Set the data for the transformer T-1:

– Controlled Node: LV

– Tap control: discrete

– Control mode: V

– Upper voltage bound 1.03 p.u.

– Voltage setpoint: 1.02 p.u.

– Lower voltage bound: 1.01 p.u.

• Run the load flow calculation with the additional option ”Automatic tap adjustment” en-
abled.

• Include the transformer tap position to the network graphic.
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5 Short-Circuit Calculation

5 Short-Circuit Calculation

In thi ample you will perform several short-circuits and evaluate the results.

5.1 Short-circuit calculation in a medium voltage grid

5.1.1 Verification of limits

• Activate the project PF Seminar with 20 kV grid enhanced. Remove the 110 kV grid from
the study case.

• Run the simulation cases a) and b) that are listed below and add the results to table 5.1.

a) 3 ph. Max short-circuit calculation at all busbars for the given network topology. Are there
any overloaded elements?

b) Change the network topology by closing the circuit-breaker at the line ”L UW1-UW3-3” (as
shown in figure 5.1) and calculate a 3 phase short-circuit at all busbars. Fill out table 3.

Table 5.1: Results short circuit medium voltage grid

Base case CB closed
Skss max
Ikss max

Unsafe network components
Infeed of wind farm ok?

Ip max
Configuration allowed?
Ideas for improvement?

Open again the circuit breaker at line ”L UW1-UW3-3” so that the original network topology is
obtained.
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5 Short-Circuit Calculation

Figure 5.1: Configuration CB opened / closed

Now switch to they 110 kV grid. Add the grid 110 kV grid to the study case again.

• Calculate a 3 phase Short-Circuit at busbar S1 of the substation UW-1 in 110 kV grid.

• Analyse the influence of the break time on the breaking current Ib. Use Comparision of
results for the analyze. [D.8]

• Analyse the influence on the fault time on Ith. Add Ith to the results shown in the result
box.

5.1.2 Short-circuit calculation on a line

• Switch over agin to the 20 kV grid.

• Calculate the 3 phase short-circuit on line ”UW1-SW1-1” . The fault location should be at
70 per cent off the line. Mind to show the results in the box for busshc (short-circuit bus).

5.1.3 Single-Phase Short Circuit

Single-Phase short-circuits are especially problematic in medium voltage grids. Thus we will
continue the short circuit training in the medium voltage grid imported earlier.

• The capacitance connected to the 20kV busbar ”UW 1 -S1” represents a further cable
capacitance. Disconnect the capacitor first.

• Calculate a single-phase short circuit current at ”UW 1-S1” according to IEC60909.

• Determine the zero-sequence impedance for the NEC element, so that the network is
compensated. Herewith please use the zero-sequence impedances (R0, X0) at the S/C
fault busbar.
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5 Short-Circuit Calculation

• Run the S/C calculation again and check if the magnitude of the current is small.

• Now please connect the capacitor to the system and calculate a single-phase S/C current
at ”UW1 -S1” again. Has the magnitude of the current changed much?

• Determine the new zero-sequence impedance for the NEC element, so that the network is
compensated again. Either use the zero sequence impedance of the NEC itself or change
the internal grounding impedance.

• Check if the magnitude of the current is again near zero.

Figure 5.2: NEC - Equivalent circuit in the zero system
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A The Project

A The Project

A.1 Creating a new project

• Main Menu : File → New. This opens the New dialog.

• Tick the option New → Project. Enter the project’s name. Make sure that the Target
Folder points to the folder in which you want to create the project (normally that is your
user account folder).

• Press OK. A grid is automatically created in the new project and a dialog will pop, enter a
name for your network.

The empty single line diagram for the newly created grid will be shown. You can now start
drawing your grid. You can change the size of the drawing area by pressing the button on the
graphics window toolbar. If you select a sub-size for printing which is smaller than the drawing
size, then the single line diagram will be split into several pages when printed. Otherwise, the
drawing area will be scaled to the printer paper automatically.

You may change the name of the project after you have created it through the main menu : Edit
→ Project. This menu-option opens the project dialog. Be careful not to change any settings or
buttons which you do not know.

You can change the name of the Study Case through the main menu : Edit → Project Data→
Study Case. Here you can change the name of the study case, but you can also change the
settings of the Grids that are activated by the study case. To change the grids, press the button
Grids. This opens a list of all Grids. You can either double-click the name to change it (press
return twice to confirm the change), or you can select the Grid that you want to change (by left-
clicking the icon in the first column), and press the Edit Object Button in the current window.

A.2 Activating and deactivating a project

There are several ways to open and close a project. The easiest way is via the main menu bar.
The last 5 active projects are listed at the File menu on the main menu. The currently active
project is the first one in this list. To deactivate the currently active project, select it in the list (left
click it). Alternatively, you may choose the option File → Close Project from the main menu.

To activate a project, select it in the list of 5 last active projects. To activate a project that is
not in the list of 5 last active projects, use the option on the main menu File → Open project.
This brings a tree with all the project in your user account. Select the project that you want to
activate.

Another way is through the Data Manager. Click the right mouse button on a project and select
Enable or Disable from the context menu.

A.3 Import a project data file (*.pfd or *.dz file)

Press Main Menu: File → Import. Then select Data (*.dz; *.pfd)... and select the project that
you want to export.

If required, press the black arrow button to select another path to which you want to import the
objects in the file. This opens a tree with all the folders in your database from which you can
select the correct target folder (normally, this would be your user account folder).
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